multilanguage question

hey,guys, I follow the tutorial https://www.storyblok.com/tp/gridsome-multilanguage-website-tutorial but still cannot change the language, I think my problem is that I miss the following setting,

 define set the fields to translatable in the schema configuration of each component. Once you configured the languages you should see a language switch like in the following screenshot.

where can I get the schema configuration of each component?
I also download this link to try,


as I click the link , the content is the same, but the language didn’t change.
thank so much!

Hello Tanyamon258963,

you need to setup the languages you want to have available here first:

After that you will have the setup languages as options in the content view available:

You need to get into the schema definition. That can be done by pressing the “Define schema” button that will lead you to the list of the fields that are part of the schema. There you choose the field that you want to change:

Now you will be able to mark the field as translatable. After checking the option translatable save the change:

After marking the fields that should be translatable you can follow the steps in the image: