Copy-pasting from Google Docs does not match style by default

When copying content from Google Docs and pasting it into RichText field using Google Chrome the output will have grey background. To avoid it, all text needs to be pasted with “Paste and Match Style” option which isn’t convenient when one has multiple fields to fill out with content from Google Docs.

Screen Shot 2021-12-15 at 09.28.38

Hello @konstantin.azizov,

this comes from the content structure that is being generated by google docs and then copied. It automatically contains different tags that are being interpreted by the richtext editor as you can see in the following video - How to remove HTML tags from copied content? - YouTube

It is also possible to remove those tags and any formatting when using the menu option Paste from Markdown.

Best regards
Hannes